Ticket #47 (defect)

Opened 7 months ago

Last modified 7 months ago

dates/times are off by time zone offset

Status: closed (fixed)

Reported by: luedi Assigned to: toby
Priority: major Milestone: 0.11.0
Component: vss2svn.pl Version: 0.10.0
Keywords: Cc:

i just converted my vss database to svn using vss2svn 0.11.0 alpha 1 and i noticed all the times are off by my timezone offset. it seems that vss2svn doesn't convert times to utc before handing them over to subversion (i'm assuming svn uses utc and vss doesn't). i live in -1000. source safe says i checked a file in on 2006-08-03 at 10:32 but subversion says i committed the same file in at 2006-08-03 00:32. files committed to subversion after the vss2svn conversion show the correct time.

-- reported by lithis

Change History

01/22/2007 07:21:08 PM: Modified by luedi

The problem is, that vss stores times as seconds in the unix epoch. The stored time is the local time and not the utc time. Since subversion thinks in UTC we need to calculate the local timeshift and turn back into utc.

Fixed in [280]

01/22/2007 07:22:09 PM: Modified by luedi

  • status changed from new to closed.
  • resolution set to fixed.

These ads are automatically generated by Google based on the content of this page. Revenue from these ads helps to pay for hosting fees of this site; however, these ads do not constitute an endorsement by PumaCode.org.